Setting up .netrc file on Mac OS X (Lion) for Git

Couple of days ago, I started using Google's code projects for Git as well. It required me to setup and use .netrc file. Here are steps I took:

  1. CD to $HOME directory and typing on command line 
  2. $ cd ~
  3. Create .netrc file
  4. $ vi .netrc
  5. Add these line to .netrc
  6. machine code.google.com login <username> password <password>
  7. Set permissions "chmod 600 .netrc" to make sure that no one else is able to access this file
  8. $ chmod 600 .netrc
  9. Now, you should be able to push and pull from remote git repo without having to enter password every time.


Android NDK vs Android SDK

This post throws some light on when to use Android SDK over NDK or vice versa. This is a on-going post and will be updated as my research continues on SDK/NDK comparison. Please leave comments if you want to contribute in this list.


NDK

  • Pros
    • Enables legacy code re-use between iOS and Android platforms
    • Good for implementing CPU intensive operations that don't allocate much memory like signal processing, physics simulations
  • Cons
    • Seems to introduce security and stability issues
    • NDK activities disables SDK feature use like broadcast receivers, content providers, services. Some better SDK libraries becomes un-usable in NDK.

SDK

  • Pros
    • Java has superior memory management model
    • Superior threading model
    • Better exception handling model
    • Rich set of libraries
    • Superior support for unicode characters
  • Cons




[GIT] How to apply Pull Request

I use "Fetch and Merge" approach to apply Pull request from a forked repo to main repo. What is actually done in this approach is to fetch changes from the forked repo in main repo working copy and merge the changes. Once changes from forked repo are merged in main repo working copy, push it to remote main repo as usual.

This process is achieved in these steps:

1- CD to main.git repo working directory
$ git checkout master

2- Add forked repo forked.git in remotes
$ git remote add <forked> <forked.git>


3- Fetch changes from forked.git
$ git fetch forked

4- Merge into master branch
$ git merge <forked>/<master>

5- Push the merged changes to main.git
$ git push origin master 

How to List Users and Groups in OSX (Mac-Lion)

To list the users :
dscl . -list /Users
To list the groups:
dscl . -list /Groups 

How to Stop a Jenkins Server

Simply, unload the jenkins from Launch daemon using:

sudo launchctl unload /Library/LaunchDaemons/org.jenkins-ci.plist

Scheduling Repeating Local Notifications using Alarm Manager

Learn about Scheduling Repeating Local Notifications using Alarm Manager in this post .